obvious flaw with this .ini ?

edited May 2013 in Help request
I'm trying to follow Sausage's tutorial 1, but cannot get the ini file right. Can anyone spot something really obvious here?

Here is the error message:
[DISPLAY] [orxTexture.c:orxTexture_CreateFromFile():651] Failed to load bitmap [tutorial-tiles.png] and link it to texture.
[DISPLAY] [orxGraphic.c:orxGraphic_CreateFromConfig():696] Couldn't get text or texture for graphic (tile1).

Assume that tutorial-tiles.png actually exists and is in a proper location
; ----------------------------------- DISPLAY ----------------------------------------- ;

[Display]
ScreenWidth   = 480
ScreenHeight  = 800

[Viewport]
Camera        = Camera

[Camera]
FrustumWidth  = @Display.ScreenWidth
FrustumHeight = @Display.ScreenHeight
FrustumFar    = 1.0
FrustumNear   = 0.0
Position      = (0.0, 0.0, -1.0)

; ---------------------------------- OBJECTS ------------------------------------------- ;

[TilesObject]
Graphic     = tile1

[TilesGraphic]
Texture     = tutorial-tiles.png
TextureSize = (80,80,0)

[[email protected]]
TextureCorner = (0,0,0)

[[email protected]]
TextureCorner = (80, 0, 0)
 
[[email protected]]
TextureCorner = (160, 0, 0)
 
[[email protected]]
TextureCorner = (0, 80, 0)
 
[[email protected]]
TextureCorner = (80, 80, 0)
 
[[email protected]]
TextureCorner = (160, 80, 0)
 
[[email protected]]
TextureCorner = (0, 160, 0)
 
[[email protected]]
TextureCorner = (80, 160, 0)
 
[[email protected]]
TextureCorner = (160, 160, 0)

Comments

  • edited May 2013
    So the only proper location for tutorial-tiles.png would be the same folder as the executable, is there where the file is?

    That tutorial was written before the Resource module was written, but now paths for textures could be provided separately, allowing for the actual file being in a different folder than the executable

    Something like this:
    [Resource]
    Texture = path/to/folder1 # ... # path/to/folderN
    

    For more details about the resource module, please check: https://bitbucket.org/iarwain/resource


    Note: The TextureCorner config property key, while still supported, is deprecated in favor to TextureOrigin, which match the internal code API. :)
  • edited May 2013
    I'm running this tutorial on android, so I've placed all the .ini and .png into the assets folder (this has worked in the bundled tutorials) and refer to it without any path (ie Texture = file.png). Hmm, so nothing stikes the eye then? Order is ok, empty lines, etc.

    PS.
    I will change TextureCorner->TextureOrigin, thanks for pointing that out.
  • edited May 2013
    Ha! Just tried using a different png in place of texture-tiles.png and everything worked... Is it the dash in the name or is the asset manager compressing the png...
  • edited May 2013
    ok, seems that the tutorial-tiles.png from the wiki is corrupted. Can't open in gimp or orx. I thought I was going crazy..
  • edited May 2013
    The dash name shouldn't matter, at least at orx level, but you can easily try this hypothesis.

    It might be an unsupported bitmap format, but lydesik would know more about this as the supported formats on Android (and iOS to some extent) differ slightly from the other platforms.
  • edited May 2013
    Ah good to know, I'll see if I can replace that file then.
  • edited May 2013
    I spoke too soon, sorry!

    I downloaded the file incorrectly somehow (using xubuntu firefox, right-click 'save link as...' vs right-click 'save image as...'). Doing the save image as actually gives proper file. So after all that, it's just a false alarm.. :S
  • edited May 2013
    Heh, that's good, less work for me! ;)
Sign In or Register to comment.