[SOLVED] Orx SVN in Ubuntu/Code::Blocks

edited April 2011 in Help request
Seems I have nothing but questions with which to bother people...

I'm trying to compile the latest SVN version of Orx using Code::Blocks in Ubuntu. I've already got it compiling fine using VS2010 in Windows, but when I tell Code::Blocks to build any one of the {Static|Dynamic} {Debug|Release} builds, they always eventually fail with:
/home/.../orx-svn/trunk/code/src/memory/orxMemory.c|38|error: malloc.c: No such file or directory|

Has anyone seen this before? I haven't changed anything in the SVN directories, so presumably the builds should still see an available malloc.c?


  • edited April 2011
    Err, well, it's only that I haven't updated the Code::Blocks project files in years. :D
    I don't even think there are configurations to build the embedded version with code::blocks.

    However, the codelite project files should be up to date. :)
    If you still want to stick with code::blocks, you might want to update some include paths for all the external dependencies (which is why malloc is not found in the /extern/dlmalloc folder) and add embedded targets (with the define __orxEMBEDDED__).
    If you do so, feel free to send me the project files and I'll update the svn. ^^
  • edited April 2011
    Ha! Well, that did it. Compiled beautifully in CodeLite. That is, I had to manually recompile a few things to ensure the use of the "-m32" flag (I do want to run this on 32-bit machines, of course), but otherwise it worked swimmingly.

  • edited April 2011
    De nada.

    I should probably add some targets to the codelite projects to enable 32/64b compiling. And compile the external dependencies in separate folders. Maybe if I get a linux64 one day I'll do that. One day...
Sign In or Register to comment.