Cannot open file: "orxd.lib"

edited September 2011 in Help request
I followed the instructions on how to configure ORX from the tutorial. For some reason, I seem to be missing something. When I build the project, I get this error message:

Build started: Project: project, Configuration: Debug Win32
1>LINK : fatal error LNK1104: cannot open file 'orxd.lib'
1>Build log was saved at "file://c:Documents and Settingsgogo3My DocumentsprojectDebugBuildLog.htm"
1>project - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Did I put something in the wrong folder? Am I missing a file? Do I need to install some sort of plug-in?

I'm using visual C++ Express Edition 08 on Windows XP.


  • edited September 2011
    Alternatively, if this is a problem with configuring Orx, is there a way that I can use notepad or something else so that I don't need to configure anything?
  • edited September 2011
    If you followed Grey's tutorial the file should be present. How did you get you copy of orx?

    At any rate, search the orx folder you downloaded for orx.lib orxd.lib and put them in the lib directory for your project (it should be beside the bin directory that your executable is in, if it is not there, create it)
    Also, locate orx.dll and orxd.dll and place them in your projects bin directory allong with your executable and config files.
  • edited September 2011
    Thanks, I'll try that.

    By the way, can I run this through My Computer and Notepad, or do I just have to use Visual C++ Express? I think maybe I got a defective version of VC++ or something, so I'd prefer to use an alternate text editor.
  • edited September 2011
    I got my version of Orx from this website, off of the Wiki(Tutorial 1: Setup Visual Studio 2008).
  • edited September 2011
    You can compile your programs using any IDE or compiler you choose (though, you may need to compile orx as well yourself if the precompiled libraries are not compatible with your choice.)

    So yes, you could use notepad to write your C files, and call the compiler and linker directly from the command line, writing the arguments by hand. But this will only make things harder on yourself.

    No, there is no escape from this configuration, one way or another you simply HAVE to tell the compiler and linker where to find orx, and how it is supposed to compile your program.
    Visual Studio already takes care of a large portion of that for you, especially with it's default settings.

    Open your properties page again, and take a look at the C/C++- > Command Line
    as well as the Linker -> Command Line properties, and you can see for yourself what you would have to write manually if you dont use an IDE.

    I assure you that your copy of visual studio is not defective, and that once you have properly told VS where to find orx (which you will need to do no matter how you build your program) it will become easy to use (or as easy as C compilers get at least.)

    Anyway, did you get the ? And did you find the bin, include and lib folders in that zip file? (probably under the folders orx-1.3rc0/dev-msvs2008/ )
    And did you merge those with your bin lib and include folder in your project directory?
  • edited September 2011
    I don't have much to add to 4babce's post except maybe that, if you're not familiar with the way compiling/linking is done in C/C++, you should probably check C/C++ beginner/tutorial sites (such as

    I'm the first to admit using/compiling C/C++ is not that intuitive at first and some languages/tool chains are much more user-friendly but once you learn and understand all the basics, everything will make much more sense. :)
Sign In or Register to comment.