SOLVED: I cannot download ORX

edited November 2011 in Help request
Hi everybody,

I have tried about 50 times to download ORX. Every time at the end of the download it says "Source file cannot be read".

I tried downloading from different browsers, nothing. I tried repairing the archive and orx.exe was missing.

And I've searched the forum before posting and didn't found somebody else asking about it.

Please help.


  • edited November 2011

    I'm not sure why you can't download the package files from sourceforge. I guess I can send it by email if you tell me which version you need.

    The other (better) option would be to sync the svn trunk and compile it yourself (it compiles out of the box for all supported platforms). This way you'd get the latest version which is much better than the last released package.

    Let me know what you prefer!
  • edited November 2011
    Actually, I'm totally new to orx so I don't know how to compile it myself(I don't know what syncing the svn trunk means :blush: ). I just want to get started. My first thought would be to ask for the latest version.
    I would appreciate it if you could send it, thank you.
  • edited November 2011
    What program are you using to unzip the files? Have you considered using a download manager? Did you disable virus scanners? (virus scanners don't like the msvs2008 version, they consider the orx executables to be viruses, even though they aren't.)
  • edited November 2011
    As per your suggestion, I tried both disabling the antivirus and using a download manager. No luck there.

    According to the download manager, it gets stuck at 99%.

    By the way, I have tried Windows Explorer, WinRAR and PowerArchiver to unzip it.
  • edited November 2011
    Are you downloading the msvs2008 build? Have you tried downloading the mingw build as well?
  • edited November 2011
    I just tried it. I can download mingw build without error.
    It's the msvs 2008 I'm having trouble with.
  • edited November 2011

    Really weird ...

    What's the exact link you tried to download ?

    This one ? : - 1.3rc0 (2513)/
  • edited November 2011
    Yes, that one. Am I the only one who has that problem?
  • edited November 2011
    Apprently yes ^^

    I tried this link, unzip and it works ... I really don't understand ...

    To have a quick solution, give me your personnal email (in a private message) and I will sent you the zip by email, it's only 4Mo, it will be ok.

  • edited November 2011
    PM sent.
  • edited November 2011
    Mail sent ;)

    (remove the "_" at the end of the filename ... gmail doesn't want to send the .zip because it contains a .exe file ...)


    Mais not sent ^^

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 delivery error: dd This user doesn't have a account ([email protected]) [-5] - (state 18).

    So, at this point, I've no idea ...
  • edited November 2011
    Lol am I cursed or something? I know I gave you the right address...

    Edit: Wait... I had it wrong. It's not, its
  • edited November 2011
    Ok, problem solved. This is what I was doing wrong:

    While I had actually disabled NOD32 Antivirus and Real-time protection through the taskbar icon, Web Access protection was still on. Nod32 was blocking it without saying anything.

    To all noobs like me using NOD32: You have to manually disable web access protection from the "Advanced Setup" to download orx.

    Everyone, thanks for your help.
  • edited November 2011
    I'm glad you found the issue and I'm sure this info will help others in the future.

    One thing's for sure, next release I won't compress any executables, this way antivirus won't complain anymore. :)

    As for Subversion (svn), it's a version control system that is used by orx on sourceforge to keep its source code (and an history over time). You can find more info directly on orx's sourceforge page as well as tutorials on how to use a svn client. On windows I'd recommend using TortoiseSVN, a client that integrates with Explorer. Here's a video tutorial (among many others on youtube):

    If you have any questions, don't hesitate.
  • edited November 2011
    Thank you. Once I get started on the engine I'll check it out.
Sign In or Register to comment.