Build latest orx for mingw or codelite

edited April 2013 in General discussions
I cant build orx for codelite or mingw using

premake4.exe codelite
premake4.exe gmake

For gmake i get the following error :
"==== Building orxLIB (embedded dynamic debug) ===="
Creating obj/Embedded Dynamic Debug/orxLIB
In file included from ../../../src/plugin/orxPlugin_EmbeddedList.cpp:76:0:
../../../include/../plugins/Sound/OpenAL/orxSoundSystem.c:2148:35: fatal error:
opening dependency file obj/Embedded Dynamic Debug/orxLIB/orxPlugin_EmbeddedList
.d: No such file or directory
compilation terminated.
orxLIB.make:691: recipe for target `obj/Embedded Dynamic Debug/orxLIB/orxPlugin_
EmbeddedList.o' failed
mingw32-make[1]: *** [obj/Embedded Dynamic Debug/orxLIB/orxPlugin_EmbeddedList.o
] Error 1
makefile:20: recipe for target `orxLIB' failed
mingw32-make: *** [orxLIB] Error 2


  • edited April 2013
    Mmh, I don't have this issue with gmake, and none of the build machines either as you can see here:

    A few questions: are you using the version of premake4 that comes with orx?
    Did you start mingw32-make from the code/build/windows/gmake folder? Have you tried to do a mingw32-make clean, just in case?
  • jimjim
    edited April 2013
    No, I downloaded premake from the net, I did not know about premake in orx. Ok, will try with that and report it

    Edit: okay, I tried with the premake that comes with orx and everything is fine :)
  • edited April 2013
    Ah yes, had to make some fixes/modifications in premake4 to make it work for orx, you can't use a vanilla one. :)
Sign In or Register to comment.