Mac OS X & Codelite

edited September 2013 in Help request
I am trying to develop predominantly on mac, and switch between OS s so I decided to use codelite, now it does not work :(, it seems close to working but I think the debug is screwing me up
So I'm starting in coding, no experience... I download codelite then start following the linux tutorial, do everything as said, so I proceed to Grey's tutorial 2 to try and get something to work.
btw I am using osx 10.6.8 and codelite 5.1
I copy paste the code...
the only things I notice are the fact that the Project.ini has a capital P, doesn't seem to be case sensitive anyway...
so then I go to the debugger and set it to use mac-1.4-dev kits debugger orxDebug.h (no Idea what I'm doing btw) and the codelite debugger returns an error of
Using gdbinit file: /var/folders/vC/vCiCUXKaGw4axZi5FdoIHk+++TI/-Tmp-/codelite_gdbinit.txt
Current working dir: /Users/SAS/Desktop/Game/My Project/project
Launching gdb from : ../bin/
Starting debugger : /Users/SAS/Desktop/Game/My Project/include/debug/orxDebug.h --command="/var/folders/vC/vCiCUXKaGw4axZi5FdoIHk+++TI/-Tmp-/codelite_gdbinit.txt" --tty=/dev/ttys003 --interpreter=mi "./project"
DEBUG>>set unwindonsignal on
DEBUG>>set breakpoint pending on
DEBUG>>set width 0
DEBUG>>set height 0
DEBUG>>set print elements 200
Debug session started successfully!

so before that is not the problem, it is the fact that ./Release is not a directory (it is supposed to be an intermediate folder, no idea...)
when I attempt to build and run it I get
-bash: ./project: No such file or directory
(dunno if I'm even building it correctly isn't it a standalone executable?)
the debugger delivers
Failed to initialize debugger:

also it says at the very start of grey's tutorial 1 to copy lib, bin, include presumably from, though in orx 1.4 there are 2 bins 1 in tools/orxCrypt, the otehr in tools/orxFontGen, I used the prior one, both do not look like what is needed though...
also I have noted that the .os on the linux tutorial is the same as .dylib on mac osx
it did mention "Please be aware, the files inside the archive are built with an older version of GCC and G++, so they will be incompatible with current releases."
But I dunno how to fix this either
anyway any help getting or to work with codelite would be helpful, if I have to use the old versions I can but I don't remember getting those to work either (only got it working on windows a few years ago)
sorry for being such an imbecile... :(


  • edited September 2013
    Hi SAS! Long time no see. ;)

    Don't worry about asking beginner questions, there'll always be someone around to help.

    First thing first though, before worrying about developing for multiple platform, if Mac is going to be your main platform, I'd use the most "user friendly" development environment there to begin with. Then when you are comfortable with that (and you are more familiar with how C/C++ programs are made), you can then go for something more advanced and less accessible.

    So to start again, I'd recommend syncing orx's source repository instead of using precompiled binaries. Three main reasons for that:
    - you get all the new cool features since the latest release + all the bug fixes
    - you won't have any outdated binaries to deal with (at least not as many ;) )
    - everything will already be at the right place (most of the time)

    Here are the main steps:

    1. Install a mercurial client (SourceTree is free on OS X and works pretty well):
    2a. Clone orx's repository using this address:
    2b. Go get a coffee, this might take a while :)
    3. Open XCode (or download/install if if it's not already the case)
    4. Open orx's XCode project located in code/build/mac/xcode/orx-embedded.xcodeproj (this one, not any other one)
    5. Compile orx (debug, profile and relase configurations)
    6. Now you're ready to continue on your adventure with any other tutorial (btw all the official tutorials will already be on your disk in the tutorial folder, but I still recommend trying to read&learn from Grey ones). You can even launch orx from XCode and you'll see my playground where I develop&test all the new features (it's called Bounce).

    Let us know if you have any trouble with any of the steps. :)

    edited September 2013
    I downloaded the source and opened it, followed code/build/mac/xcode/orx-embedded.xcodeproj
    then for step 5 I have no idea, I know that I can compile it in the 3 different configurations, with build->compile (or command+K) and change the active configuration, not really sure what any of this is anyway, but well It won't compile, I am not sure what I am supposed to select, is it one of the targets, but well I tried compiling and it failed, and now the compile option is greyed out (not a reference to grey's tutorials...)
    I do not understand what a target is, in code/build/mac/xcode/orx-embedded/ I have noticed that there is


    each of the "folders" 3 contains,,,,
    I am assuming that to compile means to take each of these 3 "folders" and compile them as separate executables?
    so well, I don't know how to select the folder

    in my traget folder section or whatever of the x code app I think it is targeted inside the debug folder hence in the target I found liborxd.dylib, and no other liborx

    a key problem is I do not seem to be able to select my sdk I managed to select Base SDK, though this I do not think works, when I create a project I can set my SDK up the top I see it appears as 10.6 | Debug |... but on the other one I managed to set the sdk to the exact same thing yet it diplays up the top Base SDK | Debug |... and when I attempt to build (just cause) I receive error: there is no SDK with the name or path 'macosx'

    basically instruction 5 is not in the x code tutorial (it is the mysterious part after...) which I don't understand anyway... I dunno step 5 seems impossible as I can no longer access the compile option or understand exactly what compiling will achieve
    am I supposed to be using an sdk?

    gaah, I have no idea :( ...

    (not angry (raging, hahaha) just saving time)
    step 5 how do I compile is the question in short
    confusion is in SDK, targets, what is compiling/why

    thanks (sorry if this is kinda crap but its 6:16am, so I should sleep, before I forget I'm using mac osx 10.6.8 and X code 3.2.1)
  • edited September 2013
    SAS wrote:
    I downloaded the source and opened it
    Hold it right there! :)

    There's nothing to "download and open", so me think you're screwed even before beginning. ;)

    Orx's source is stored on a Mercurial (hg) repository on You need a Mercurial client in order to clone the whole repository, that's why I mentioned SourceTree which is a free Mercurial client. Then do these steps:

    1. Open SourceTree
    2. If no windows shows, go to File->New, otherwise it should ask you which path to use for cloning a repo
    3. Use this path:
    4. Select whichever local directory works for you, that's where orx will end up on your machine
    5. Click the clone button
    6. About that coffee, right now is the right time. :)

    When the repo is cloned, you'll have all the sources in orx/code, all the external dependencies in orx/extern and all the tutorials in orx/tutorial.

    Now in XCode (we have the same version, btw), open the project in orx/code/build/mac/xcode named orx-embedded.

    Select Debug as config, all as Target and the rest doesn't matter. Later you can pick the Profile and Release configs as well, never change the Target.

    Command + B to build.
    When it's done, you should be able to run my playground with Command + Y, and you'll find the library itself in code/lib/dynamic (on OS X their extension is .dylib, equivalent of .dll on windows and .so on linux).

    Grey's tutorial are not entirely adapted to OS X but beside the difference I just mentioned, everything else should be similar (except you're using XCode).

    If you get this working, we can then try to go with codelite as our next step, let me know. :)
    edited September 2013
    Should I try to submit a tutorial for this with pics... later (got some stuff to do atm, also as in the tutorial is a new updated mac tutorial)
    btw I am not stupid I tried to use mercurial but it came up with errors, it still is, dunno if that's supposed to happen but the loading bar is moving so I guess I'll leave it for a bit
    it just says not verified, assuming that's a security issue... (kinda not really...)

    anyway thanks I'll see how it goes :)
    edited September 2013
    THUD! (bangs head on desk)
    I just realised that it was in fact not downloading, well not just realised I just realised that it actually was downloading and that the loading bar is non-functional in mercurial, can't believe I didn't get info on the folder before, I only picked up on it after realising the folder I created was removed every time I aborted :) yay
    only took an hour to get nowhere :/
    well shouldn't be long now, oh btw I will actually have time for a tutorial as it has nothing that can go catastrophically wrong :)
    thanks :)
  • edited September 2013
    Progress is good and a tutorial would be more than welcome, thanks! :)
    edited October 2013
    Well I still can't manage to build the project, it comes up with the error attached, I can't seem to locate the dependency, I'm going to try to switch to windows, I installed custom drivers for my mac hardware, it now makes a whining sound but can run most programs.
    So hopefully coding should work, so looks like I won't be able to make a tutorial as nothing is working, it is still more convenient to code on mac so if you can help that would be nice, thanks :) Screen_shot_2013_10_15_at_8.png
  • edited October 2013
    It looks like somehow you don't have Mac OS SDK installed.
    Not sure how that can happen as every time I've installed XCode, it came with the SDK as well.
    Maybe it's simply not the correct version?
    I'm no XCode expert unfortunately so you might have to ask on a forum dedicated to Mac development if no one has an answer for you here.
    Everything should be working out of the box on Windows though, and if you ever decide to install Linux, Katarak created a wiki page for all the dependencies:
    edited October 2013
    thanks, yeah its the fact that the sdk has the a different name it is not called macosx, so I don't know if orx is trying to access an sdk that doesn't exist, but I dunno anyway, that attached images are all I can really go on

    the other one in place of the "MAC OS X 19.6" has "macosx", which is not an sdk (I think) Screen_shot_2013_10_16_at_5.png

    oh and btw the screenshot was taken from within the info of orx-embedded, which means that you just double click it :)

    I just needed to google the problem, I think the problem is that there is as I said no sdk at least for me called "macosx", wow, thank you google!
    Well I couldn't find these with the word search I'll try to edit them, anyway if I haven't then maybe some advice may be nice, as I don't think something so simple will fix it. Anyway thanks :)

    yeah I'm lost, can find it :/
    Also if I were to switch to windows due to it being the majority, so it should be smoother what version of Visual studion should i get?
    Thanks :)
  • edited October 2013
    Mmh yes, sorry, I can't really help you with the Mac version as I'm stuck with old versions of the OS/XCode/SDK due to Apple not releasing those for older machines. :(

    As for visual studio, I'm using vs2008 myself but I think the majority is using vs2010.

    I wouldn't recommend vs2012 though as you'd then have to compile all the dependencies after converting their project files. :)
    edited October 2013
    Isn't it a matter of just changing the sdk which it will compile with or does it only compile with older sdk s that you have?, so if I could find the code that I just need to change the directories n stuff, anyway if its too much of a bother that's fine all mac users can dual boot like I have anyway, I'll start downloading Visual studio, yeah it just seems like a simple matter though it could be intergral, as I have no idea how specific orx is with its compilation.
    Anyway I could give it a shot I just need to know what files contain this text, as I cannot really understand where the macosx text is that I need to change, anyway I have the 10.5 sdk obviously, but don't have the macosx sdk/directory/whatever it is, if you actually know what that is reffering to I could find an equivalent.
    anyway thanks, you can just say no :)
  • edited October 2013
    Yep, if your SDK is 10.5, simply changing it in the settings of XCode (the one from your screenshot) should work just fine.

    If it were newer than 10.6 however, you'd have to re-compile the external dependencies as well.
Sign In or Register to comment.