How to get started?

edited October 2017 in Help request
I have worked through the tutorial.
But I still have no idea how to start one project from the scratch. How can I deal with this package? Is there any documentaion I could read?


  • edited October 2017
    Hi, Reedsye, was it the beginner's tutorial that you used from here?

    There is something new to orx that may help you get started a little quicker and it might be helpful to us if you would like to try it out.

    If you use the git version of orx, there are scripts there to help you auto-generate a project.

    That will help you be up and going in a few minutes. I can certainly help you through this.

    Are you familiar with using git?

    If not, I can help you through the beginner's tutorial to get you started.
  • edited October 2017
    Thank you for your help!
    Yes, I used that beginner's tutorial.
    I am very glad to learn how to use git and the auto-generater you have mentioned.
    Please help me with it!
  • edited October 2017
    If you want to learn how to git, there is a good one hour video here:

    Depends if you want to go down that path.

    Alternatively, we can continue to try with what you have now, and you can let me know where exactly you got stuck with the tutorial.
  • edited October 2017
    thank you
    I will try it
  • edited October 2017
    can you type out the url for this video?
    It shows blank here.
  • edited October 2017
    Sorry about that, the forum is being weird. I edited the post. You should be able to copy the link now.
  • edited October 2017
    @ReedsEye, also don't forget, if getting started with git all a bit much right now, and you just want a project to get started playing with Orx, you can change the tutorial project as outlined in the beginners tutorial.

    If you get stuck on any step, let me know what the error or problem is and I should be able to sort you out.
  • edited October 2017
    Hi Reedsye and welcome here!

    To complement sausage's replies, don't hesitate to come and see us on the chat if you feel like it. Sometimes it's better for faster step-by-step support:
  • edited October 2017
    When I do the beginner's tutorial in another computer, during doing "Part 3 - Setting up a new game project" VS 2015 shows this error.
    I googled it and found no useful suggestion, What could I do to solve it?

    error MSB3073 “cmd /c copy /Y ........codelibdynamicorx*.dll
    :VCEnd” , 1 . 01_ObjectC:Program Files (x86)MSBuildMicrosoft.Cppv4.0V140Microsoft.CppCommon.targets133
  • edited October 2017
    It looks like the forum mangled the error message. However it looks like it's the copy step for the .dll, which means that it's likely that the engine library hasn't been compiled (orx.dll).
    Did you compile the release config version of orx beforehand? Sorry, I don't know the details of the steps of the tutorials, sausage will probably be able to help you more with that.
  • edited October 2017
    To compliment Iarwain's answer, if the orx library has been compiled successfully, you need to make sure that your project is near the orx project so that it can find the library:

    From the error in your path:

    Your orx code folder needs to be at the relative path listed above.

    A quick alternative to get it working is to copy all the *.lib files into the /lib folder of your project, and the orx*.dll files into the /bin folder of your project.

    Then make sure you copy the include folder from orx, to your project.

    That's a quick cheap way to get it working.

    Then later, you can go back and make sure your project paths are correct so that you can get it working properly.
  • edited October 2017
    I tried the Tutorial.sln and changed nothing. When building the project, the same problem still occurred.

    The file I used is in the tutorial. The .dll and .lib files are in proper folders.
  • edited October 2017
    Ah yes, this was fixed post-1.8 released. You can simply remove the copy step.

    Another approach is to simply clone the git (or hg if you prefer) repository. You'll have all the latest features, include the 'orx init' one to start a new project, and everything is where it should be. You simply need to run setup.bat once after cloning the repository.
  • edited October 2017
    Alternatively, you can also simply ignore the error itself, it should run just as well.
  • edited November 2017
    Hi Reedsye,

    There has been a bit of work behind the scenes to make the git version of orx (and git itself) easy to download and use.

    Also, easier to set up your own project.

    We've revised many of our instructions, if you'd like to make another attempt at it. Starting from here, you should find things make better sense:

    Let me know if I can help you in any way.
Sign In or Register to comment.