"orx.h": No such file or directory

Hello!

I followed this setup-guide and this building-setup for Orx (Windows 10). Both worked without any errors but when I open the project (created with init) VisualStudio say: ' [...]: "orx.h": No such file or directory '.
Because I worked before with SFML I added the "include" and "lib" directorys in the project setting but nothing changed. Recreating the project (init) doesnt helped. I didnt found my problem in the forum so I created this discussion! I hope somebody can/will help me!

Thanks!

Greetings from germany!

Comments

  • Hi @CrazyFinn_ and welcome here!

    When running setup.bat, an environment variable named ORX is set with the path leading to your orx's code folder.
    This is what is used later on to compile and build projects with the engine.

    Could you verify that this environment variable is correct on your side by running set ORX in a console?

    Here's mine:

    λ set ORX
    ORX=C:\workspace\orx\code
    

    If your IDE is already opened before you run setup.bat, you might have to close and restart it in order to pick the new value of the environment variable.

    Let us know how it goes! :)

  • edited August 30
    Yeah, the value is right.
    ORX: C:\Users\Finn\Desktop\orx\code

    My Project are at a different directory is that a problem?
    D :\OrxProjects
  • Im so stupid.. I moved the orx folder from my download folder to my desktop.. I didnt read the ORX-directory correct ^^ So I changed the directory and recreated the project and now its working ... Thanks for your help :blush:

  • Nice, I'm glad you have it working now. :)

    Don't hesitate if you have any questions or comments!

Sign In or Register to comment.